链路聚合简介_链路聚合个人资料_链路聚合微博_百科网
A-A+

链路聚合简介_链路聚合个人资料_链路聚合微博

2016-11-29 00:23:37 科学百科 阅读 2 次

原理/链路聚合 编辑

链路聚合
链路聚合

逻辑链路的带宽增加了大约(n-1)倍,这里,n为聚合的路数。另外,聚合后,可靠性大大提高,因为,n条链路中只要有一条可以正常工作,则这个链路就可以工作。除此之外,链路聚合可以实现负载均衡。因为,通过链路聚合连接在一起的两个(或多个)交换机(或其他网络设备),通过内部控制,也可以合理地将数据分配在被聚合连接的设备上,实现负载分担。

因为通信负载分布在多个链路上,所以链路聚合有时称为负载平衡。但是负载平衡作为一种数据中心技术,利用该技术可以将来自客户机的请求分布到两个或更多的服务器上。 聚合有时被称为反复用或IMUX。如果多路复用是将多个低速信道合成为一个单个的高速链路的聚合,那么反复用就是在多个链路上的数据"分散"。它允许以某种增量尺度配置分数带宽,以满足带宽要求。链路聚合也称为中继。

按需带宽或结合是指按需要添加线路以增加带宽的能力。在该方案中,线路按带宽的需求自动连接起来。聚合通常伴随着ISDN连接。基本速率接口支持两个64kbit/s的链路。一个可用于电话呼叫,而另一个可同时用于数据链路。可以结合这两个链路以建立l28kbit/s的数据链路。

链路聚合有如下优点:

1、增加网络带宽

链路聚合可以将多个链路捆绑成为一个逻辑链路,捆绑后的链路带宽是每个独立链路的带宽总和。

2、提高网络连接的可靠性

链路聚合中的多个链路互为备份,当有一条链路断开,流量会自动在剩下链路间重新分配。

链路聚合的方式主要有以下两种:

1、静态Trunk

静态Trunk将多个物理链路直接加入Trunk组,形成一条逻辑链路。

2、动态LACP

LACP(Link Aggregation Control Protocol,链路聚合控制协议)是一种实现链路动态汇聚的协议。LACP协议通过LACPDU(Link Aggregation Control Protocol Data Unit,链路聚合控制协议数据单元)与对端交互信息。

激活某端口的LACP协议后,该端口将通过发送LACPDU向对端通告自己的系统优先级、系统MAC地址、端口优先级和端口号。对端接收到这些信息后,将这些信息与自己的属性比较,选择能够聚合的端口,从而双方可以对端口加入或退出某个动态聚合组达成一致。

链路聚合往往用在两个重要节点或繁忙节点之间,既能增加互联带宽,又提供了连接的可靠性。

冗余协议/链路聚合 编辑

VRRP(虚拟路由器冗余协议)是这样一种协议,它允许一个多路访问链路上的几个路由器利用同一个虚拟IP地址。控制虚拟路由器IP地址的 VRRP 路由器称为主路由器,它负责转发数据包到这些虚拟IP地址。一旦主路由器不可用,这种选择过程就提供了动态的故障转移机制,这就允许虚拟路由器的IP地址可以作为终端主机的默认第一跳路由器。使用VRRP的好处是有更高的默认路径的可用性而无需在每个终端主机上配置动态路由或路由发现协议。 VRRP 包封装在 IP 包中发送。VRRP使路由器自动绕过故障而路由,从而确保了网络的不间断运行。

使用 VRRP ,可以通过手动或 DHCP 设定一个虚拟 IP 地址作为默认路由器。虚拟 IP 地址在路由器间共享,其中一个指定为主路由器而其它的则为备份路由器。如果主路由器不可用,这个虚拟 IP 地址就会映射到一个备份路由器的 IP 地址(这个备份路由器就成为了主路由器)。 VRRP 也可用于负载均衡。 VRRP 是 IPv4 和 IPv6 的一部分。

ALB/链路聚合 编辑

吞吐量

ALB(自适应负载平衡)Intel开发了ALB以满足带宽密集环境中吞吐量的要求。使用ALB,4条lOOMbit/s的以太网信道就可在交换机和服务器之间组合成一条单个的400Mbit/s的信道。在服务器中安装适配器卡,并配置这些卡以便在ALB下作为一个“小组”一起运行。所有的适配器都用导线连接到一个单个的交换机。它们向可路由传输通信量提供负载平衡,并向具有两个或八个连接到同一个交换器的适配器的组提供适配器容错。该软件分析每个适配器上的发送和传输负荷,并根据目的地址来平衡适配器间的负荷率。ALB给整个小组分配一个单一的网络地址。ALB软件驱动程序包括一个智能的自适应代理,该代理通过动态分析服务器来的通信流,在链路之间均匀分布数据通信量。

Cisco Fast Ether Channel

(快速以太网信道)Fast Ether Channel(FEC)是Cisco开发的一种中继技术,该技术可均衡校园主干网络环境中的链路。它将2~4个全双工快速以太网信道组合在一起,从而在交换机、路由器和服务器之间提供容错高速链路。对于快速以太网,带宽可以200Mbit/s到800Mbit/s增量式扩展。使用吉比特以太网,Fast EtherChannel的容量将增加到多吉比特的容量。

配置/链路聚合 编辑

实验要求

设备 IP Mask 端口

交换机A 192.168.1.11 255.255.255.0 0/0/1-2 trunking

交换机B 192.168.1.12 255.255.255.0 0/0/3-4 trunking

PC1 192.168.1.101 255.255.255.0交换机A0/0/23

PC2 192.168.1.102 255.255.255.0交换机B0/0/24

如果链路聚合成功,则 PC1 可以ping 通 PC2。

实验步骤

第一步:正确连接网线,交换机全部恢复出厂设置,做初始配置,避免广播风暴出现

交换机A:

switch#config

switch(Config)#hostname switchA

switchA(Config)#interface vlan 1

switchA(Config-If-Vlan1)#ip address 192.168.1.11 255.255.255.0

switchA(Config-If-Vlan1)#no shutdown

switchA(Config-If-Vlan1)#exit

switchA(Config)#spanning-tree

MSTP is starting now, please wait...........

MSTP is enabled successfully.

switchA(Config)#

交换机B:

switch#config

switch(Config)#hostname switchB

switchB(Config)#interface vlan 1

switchB(Config-If-Vlan1)#ip address 192.168.1.12 255.255.255.0

switchB(Config-If-Vlan1)#no shutdown

switchB(Config-If-Vlan1)#exit

switchB(Config)#spanning-tree

MSTP is starting now, please wait...........

MSTP is enabled successfully.

switchB(Config)#

第二步:创建port group

交换机A:

switchA(Config)#port-group 1

switchA(Config)#

验证配置:

switchA#show port-group detail

Sorted by the ports in the group 1:

--------------------------------------------

switchA#show port-group brief

Port-group number : 1

Number of ports in port-group : 0 Maxports in port-channel = 8

Number of port-channels : 0 Max port-channels : 1

switchA#

交换机B

switchB(Config)#port-group 2

switchB(Config)#

第三步:手工生成链路聚合组(第三、四步任选其一操作)

交换机A:

switchA(Config-Port-Range)#port-group 1 mode on

switchA(Config-Port-Range)#exit

验证配置:

switchA#show vlan

VLAN Name Type Media Ports

---- ------------ ---------- --------- -------------------

1 default Static ENET Ethernet0/0/3 Ethernet0/0/4

Ethernet0/0/5 Ethernet0/0/6

Ethernet0/0/7 Ethernet0/0/8

Ethernet0/0/9 Ethernet0/0/10

Ethernet0/0/11 Ethernet0/0/12

Ethernet0/0/13 Ethernet0/0/14

Ethernet0/0/15 Ethernet0/0/16

Ethernet0/0/17 Ethernet0/0/18

Ethernet0/0/19 Ethernet0/0/20

Ethernet0/0/21 Ethernet0/0/22

Ethernet0/0/23 Ethernet0/0/24

Port-Channel1

switchA# !port-channel1已经存在

交换机B:

switchB(Config)#int e 0/0/3-4

switchB(Config-Port-Range)#port-group 2 mode on

switchB(Config-Port-Range)#exit

验证配置:

switchB#show port-group brief

Port-group number : 2

Number of ports in port-group : 2 Maxports in port-channel = 8

Number of port-channels : 1 Max port-channels : 1

switchB#

第四步: LACP动态生成链路聚合组(第三、四步任选其一操作)

switchA(Conifg-Port-Range)#port-group 1 mode active

验证配置:

switchA#show vlan

VLAN Name Type Media Ports

---- ------------ ---------- --------- -------------------

1 default Static ENET Ethernet0/0/3 Ethernet0/0/4

Ethernet0/0/5 Ethernet0/0/6

Ethernet0/0/7 Ethernet0/0/8

Ethernet0/0/9 Ethernet0/0/1

Ethernet0/0/11 Ethernet0/0/1

Ethernet0/0/13 Ethernet0/0/1

Ethernet0/0/15 Ethernet0/0/1

Ethernet0/0/17 Ethernet0/0/1

Ethernet0/0/19 Ethernet0/0/2

Ethernet0/0/21 Ethernet0/0/2

Ethernet0/0/23 Ethernet0/0/2

Port-Channel1

switchA# !port-channel1已经存在

交换机B:

switchB(Config)#interface ethernet 0/0/3-4

switchB(Conifg-Port-Range)#port-group 2 mode passive

switchB(Config)#interface port-channel 2

switchB(Config-If-Port-Channel2)#

验证配置:

switchB#show port-group brief

Port-group number : 2

Number of ports in port-group : 2 Maxports in port-channel = 8

Number of port-channels : 1 Max port-channels : 1

switchB#

第五步:使用ping命令验证

使用PC1 ping PC2

交换机A 交换机B 结果 原因

0/0/1 0/0/3 通链路聚合组连接正确

0/0/2 0/0/4

0/0/1 0/0/3 通 拔掉交换机B端口4的网线,仍然可

0/0/2 以通(需要一点时间),此时用show

常见问题/链路聚合 编辑

1. LACP

- LACP是基于IEEE802.3ad标准实现链路动态汇聚的协议。用LACPDU与对端口协商。

在启动一个端口的LACP后,该端口发送LACPDU向对端通告自己的属性 (优先级、系统 MAC、端口优先级、端口号、操作Key。) 对端接收到这些信息后,和自己的属性比较,选择能够汇聚的端口,这样双方可以决定那对端口加入或退出这个聚合链路。

- Cisco交换机提供两种链路聚合协议:Cisco私有的PAgP、IEEE的LACP。

- 这个CCNA LACP教程显示LACP 的配置,协商、检查。协商部分是PAgP-LACP端口间的协商,没有包括LACP-LACP端口间的属性协商的细节。

- LACP: Link Aggregation Control Protocol,链路汇聚控制协议

LACPDU: Link Aggregation Control Protocol Data Unit,链路汇聚控制协议数据单元

2.使用PAgP配置,以太通道协商成功两端交换机需要采用哪种模式?

答:On----On desirable-----desirable desirable----auto

3. 封装以太通道的接口有哪些要求?

答:捆绑接口必须属于同一vlan。如果是truck,捆绑端口必须属于truck模式;具有相同的 native-vlan ID;每个接口都必须有相同的速度和双工模式;生成树设置必须一致。

中兴/链路聚合 编辑

操作步骤:——链路聚合(Link Aggregation

方案一 静态链路聚合----3228-1交换机配置如下:

1、配置vlan

ZXR10(config)# vlan 10

链路聚合
链路聚合

ZXR10(config-vlan)#exit

ZXR10(config)# vlan 20

ZXR10(config)#exit

ZXR10(config)#interface fei_1/1 ――――――――-接PC机

ZXR10(config)#exit

ZXR10(config)#interface fei_1/2 ――――――――-接PC机

ZXR10(config)#exit

2、创建SMARTGROUP 组,并设置为静态

ZXR10 (config)# interface smartgroup1

ZXR10(config-if)# smartgroup mode on

ZXR10(config-if)#exit

3、将端口加入到链路聚合组中:

ZXR10 (config)# interface fei_1/15 ―――――――――――-接3228-1的15口

ZXR10 (config-if)# smartgroup 1 mode on--------以静态方式将端口成员加入链路聚合组

ZXR10 (config)# interface fei_1/16 ―――――――――――-接3228-1的16口

ZXR10 (config-if)# smartgroup 1 mode on--------以静态方式将端口加入链路聚合组

ZXR10 (config-if)#exit

4、配置链路聚合组模式:

ZXR10 (config)# interface smartgroup1-------进入虚拟链路聚合组1

ZXR10 (config-if)# switchport mode trunk-------修改虚拟链路聚合组1的模式为TRUNK

20----虚拟链路聚合组1承载VLAN 10,20

ZXR10 (config)#exit

(3228-2交换机配置同3228-1一样)

方案二:动态链路聚合----3228-1交换机配置如下:

1、配置vlan

ZXR10(config)# vlan 10

ZXR10(config-vlan)#exit

ZXR10(config)# vlan 20

ZXR10(config)#exit

ZXR10(config)#interface fei_1/1 ――――――――-接PC机

ZXR10(config-if)#switchport access vlan 10

ZXR10(config)#exit

ZXR10(config)#interface fei_1/2 ――――――――-接PC机

2、创建链路聚合(Link Aggregation):---------

ZXR10 (config)# interface smartgroup1

ZXR10 (config-if)#smartgroup mode 802.3ad //(1、on是静态聚合2、802.3ad是动态链路聚合,此条语句不是所有的交换机都需要配置,需要具体查看相关命令)

ZXR10 (config-if)#exit

3、将端口加入到链路聚合组中:

ZXR10 (config)# interface fei_1/15 ―――――――――――-接3228-1的15口

ZXR10 (config-if)# smartgroup 1 mode active(/passive)

ZXR10 (config)# interface fei_1/16 ―――――――――――-接3228-1的16口

ZXR10 (config-if)# smartgroup 1 mode active(/passive)

4、配置链路聚合组模式:

ZXR10 (config)# interface smartgroup1

ZXR10 (config-if)# switchport mode trunk

ZXR10(config-if)#switchport trunk vlan 10,20

ZXR10 (config)#exit

注:聚合模式设置为on时端口运行静态trunk,参与聚合的两端都需要设置为on模式。聚合模式设置为active或passive时端口运行LACP,active指端口为主动协商模式,passive指端口为被动协商模式。配置动态链路聚合时,应当将一端端口的聚合模式设置为active,另一端设置为passive,或者两端都设置为active。

三、查看配置结果:

1、查看smartgroup 信息:

ZXR10 (config)#show lacp 1 internal

2、查看vlan信息:

ZXR10 (config)#show vlan

3、查看端口信息:

ZXR10 (config)#show interface brief

四、验证配置结果:

1、不同交换机的相同vlan是否通。

2、不同交换机的不同vlan是否通。

3、拔掉smarttrunk中的任何一个端口,看看对通讯有没有中断。